Menu

Connexion



Retenir ?

Mot de passe oublié ?
Eclipso logo
Merry Christmas !
06/06/2020 12:17:22

2k3 < VX < Ace < XP

[Résolu] Bug AT system mog

Shiro inuzuki

Apprenti
Shiro inuzuki
  • Messages : 155

[Résolu] Bug AT system mog


dim. 21 juil. 2013 - 14h59

Salut à toutes et à tous !

Aujourd'hui,petit problème entre les scripts MOG at system et le ace battle symphony de yami.
Je m'explique,au début du combat,la barre d'atb s'affiche,se remplit donc jusque là tout va bien sauf que au moment de l'attaque du personnage dont l'atb est pleine erreur script dans le Game_actor à la ligne 684 avec comme message "undefined method '>=' for nil:class"
La ligne en question étant " return false if @action_input_index >= @actions.size - 1" dans le bloc

Spoiler

#--------------------------------------------------------------------------
# * To Next Command Input
#--------------------------------------------------------------------------
def next_command
return false if @action_input_index >= @actions.size - 1
@action_input_index += 1
return true
end

J'ai éssayé de changer la valeur de actions.size à 0 mais cela bug à nouveau et crée un boucle avec mon perso ^^'


Please help me

coordialement

Shiro

RitoJS

6307
RitoJS
  • Messages : 6307

[Résolu] Bug AT system mog


dim. 21 juil. 2013 - 15h04

Je doute que ces deux script soit compatible.





Merci à Maki et KuroFidy pour ces cadeaux:

Spoiler



Shiro inuzuki

Apprenti
Shiro inuzuki
  • Messages : 155

[Résolu] Bug AT system mog


jeu. 25 juil. 2013 - 20h49

On peut déplacer dans résolu ^^